Member Center Computer Requirements

The Member Center requires a web browser(i.e. Internet Explorer, Mozilla Firefox, Google Chrome, Apple Safari, etc.)  that can handle web standards and Javascript well. The best results come from using an up-to-date browser.  The Virtual Classroom requirements are a little more strict.

Virtual Classroom Requirements

 

Windows Platforms

Mac OS X Platforms

iOS (iPad)2

Android Tablet2

Operating System (OS)

Windows XP, Vista, 7, 8, 8.1, 10

10.8 +

Limited1  - 10.5, 10.6, 10.7 (Leopard, Snow Leopard)

Minimum: iOS 6.0

Minimum: 2.3.3

Recommended
Web Browsers

Mozilla Firefox™ 17.0 or newer
Google Chrome® 23.0 or newer

Mozilla Firefox™ 17.0 or newer
Google Chrome®

Apple Safari®

Mozilla Firefox™
Google Chrome®

Supported Browsers Internet Explorer® 10 or newer

Apple Safari®

- the built in browser
Unsupported Browsers Internet Explorer® 9.0 or older   - -
Additional Hardware Speakers if not included - - -
Optional Headset or headphones
  1. Java is needed to run on older versions of OS X. You will need to install Java (minimum Java 7 Update 55) and use Firefox or Safari as your browser.
  2. We can only offer limited support on the iPad and Android devices. For the best online learning experience, the use of a laptop or desktop computer is HIGHLY recommended.

Learn more: Connecting to the Virtual Classroom

Read 10347 times Updated on August 25, 2016